BASIC

Author Topic: "plim!" sound when compiling on GLBv14.106  (Read 1855 times)

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4234
    • View Profile
    • Portfolio
Long ago I got that, now I´m having it again.
Everytime I compile from the ide I get a windows warning sound.
Everything works fine though.

Does anyone know anything about this?

edit: could it have anything to do with the system sound? I notice as soon as the compiled game runs, the volume keys on keyboard stays unresponsive for about 10 seconds and then it computes.
« Last Edit: 2016-Jun-09 by erico »

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: "plim!" sound when compiling on GLBv14.106
« Reply #1 on: 2016-Jun-09 »
It's due to a non-standard window size being selected when setting up/displaying your screen resolution. Try using windowed/full screen options (0 or 1) when setting up your resolution to see if it stops.
I came. I saw. I played.

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4234
    • View Profile
    • Portfolio
Re: "plim!" sound when compiling on GLBv14.106
« Reply #2 on: 2016-Jun-09 »
Great hint!

It was my settings on the project options. It had a fullscreen marked there and I have a 9999x9998 resolution set.
But the culprid is the fullscreen set on the project options.

I still have a ~10 seconds delay before my keyboard volume keys will respond after a GLB game compile and runs.
But that I guess is not a problem. The plim sound was driving me nuts.

Thanks Ian :booze:

Offline Ian Price

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 4147
  • On the shoulders of giants.
    • View Profile
    • My Apps
Re: "plim!" sound when compiling on GLBv14.106
« Reply #3 on: 2016-Jun-09 »
Can't help with the keyboard volume issues, but at least you have one less thing to worry about now!
I came. I saw. I played.

Offline erico

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 4234
    • View Profile
    • Portfolio
Re: "plim!" sound when compiling on GLBv14.106
« Reply #4 on: 2016-Jun-09 »
It´s fine, the delay is probably related to some bizarre system changes I did to deal sound codecs.
Thanks again for the lead! :good:

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3684
    • View Profile
    • Space Fractal
Re: "plim!" sound when compiling on GLBv14.106
« Reply #5 on: 2016-Jun-09 »
Im have allways disabled any windows sounds..... Mine game is allways start in 640x480 windows (or around) and then detect the desktop resolution and select that as fullscreen....
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.