BASIC

Author Topic: Android Compile problems.  (Read 1357 times)

Offline Paul Smith

  • Mr. Polyvector
  • ***
  • Posts: 109
    • View Profile
Android Compile problems.
« on: 2015-Mar-11 »
Installed Android extras as i was curious, and now messed up my settings.
I've uninstalled it which logged 100s of non declared items errors when compiling.
I've reinstalled GLB which has fixed this but now I can't point the compile to my phone
any idea where this is configured.
I dont really want to wipe this laptop.
cheers
Amstrad CPC 6128, ATARI STE.
Acer  SW5-173 & AMD FX 8350/1050Ti

Offline Paul Smith

  • Mr. Polyvector
  • ***
  • Posts: 109
    • View Profile
Re: Android Compile problems.
« Reply #1 on: 2015-Mar-12 »

I'm getting this now,  dont even know what proguard is.I should have left well alone, I guess AE changed a lot of settings.
Oh well.Maybe spacefractal should put a warning saying "Not for idiots" on the download page


*** Configuration: ANDROID ***
precompiling:
GPC - GLBasic Precompiler V.10.053 SN:1e3d04c5 - 3D, NET
Wordcount:1240 commands
compile+link:
running glb_build.bat
Using ANDROID_TARGET="android-8"
You can use "C:\Users\PaulsLaptop\Documents\GLBasic\Andriod Reset\distribute\Android\glb_android_build.bat" to change the API level and SDK path.
%ANDROIDSDK% not set. Using GLBasic's default target-8, Android 2.2



BUILD STAGE 1: Compile and pack RELEASE
Updated project.properties
Updated local.properties
Updated file C:\Users\PaulsLaptop\Documents\GLBasic\Andriod Reset\distribute\Android\build.xml
Updated file C:\Users\PaulsLaptop\Documents\GLBasic\Andriod Reset\distribute\Android\proguard.cfg
It seems that there are sub-projects. If you want to update them
please use the --subprojects parameter.

BUILD FAILED
Q:\Compiler\platform\android\android-sdk-windows\tools\ant\build.xml:539: The following error occurred while executing this line:
Q:\Compiler\platform\android\android-sdk-windows\tools\ant\build.xml:568: null returned: 1

Total time: 2 seconds
Picked up _JAVA_OPTIONS: -Xms256m -Xmx512m
.
BUILD STAGE 2: Build DEBUG and install on device
     [echo] Gathering info for glbasic...
     [echo] Creating output directories if needed...
     [echo] ----------
     [echo] Handling aidl files...
     [echo] ----------
     [echo] Handling RenderScript files...
     [echo] ----------
     [echo] Handling Resources...

BUILD FAILED
Q:\Compiler\platform\android\android-sdk-windows\tools\ant\build.xml:539: The following error occurred while executing this line:
Q:\Compiler\platform\android\android-sdk-windows\tools\ant\build.xml:568: null returned: 1

Total time: 2 seconds
Picked up _JAVA_OPTIONS: -Xms256m -Xmx512m
finished Android build-script.
Android=C:\Users\PaulsLaptop\Documents\GLBasic\Andriod Reset\distribute\Android
success
_______________________________________
*** Finished ***
Elapsed: 24.4 sec. Time: 22:43
Build: 1 succeeded.
Amstrad CPC 6128, ATARI STE.
Acer  SW5-173 & AMD FX 8350/1050Ti

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3682
    • View Profile
    • Space Fractal
Re: Android Compile problems.
« Reply #2 on: 2015-Mar-12 »
it's a androidmanifest.xml and/or icon error (stock glbasic uses api-8 and Android extras uses api-19, where I'm uses various incompatible features against stock glbasic).

Also you don't uses android extras yet. If you used that previous, then clean the distribute folder and try again. But you should Eventuelly reinstall android extras too.

Often it's help to clean up src and libs dir when updating.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline Paul Smith

  • Mr. Polyvector
  • ***
  • Posts: 109
    • View Profile
Re: Android Compile problems.
« Reply #3 on: 2015-Mar-12 »
Did a clean up this mornings and all is well. next time I'll read the instructions. will setup a fresh install on my main PC.

Cheers Spacefractal
Amstrad CPC 6128, ATARI STE.
Acer  SW5-173 & AMD FX 8350/1050Ti