Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Kosta

Pages: 1 [2] 3 4 ... 11
16
GLBasic - de / Re: GP2x Wiz- Programmierung
« on: 2009-Jun-22 »
Im 2D-Bereich: Die Roto-/Zoom- Befehle (vor allem die Roto-Befehle) zum Spritezeichnen haben bei mir beim GP2X programmieren immer die Performance runtergerissen. Der Rest l?uft eigentlich normal.

17
GLBasic - de / Re: Eure Projekte
« on: 2009-May-18 »
Ich bin (wie im Blog erw?hnt) mit meinem horizontal-scrollenden Shooter besch?ftigt.
Wobei ich seit einem halben Jahr nichts mehr dran gemacht habe.

Habe einfach keine Zeit mehr.


18
GLBasic - de / Re: GPS f?r Windows Mobile
« on: 2009-May-15 »
Ich wollte mal das Testprogramm (unver?ndert) f?r WinCE kompilieren...

wo hakts?

_______________________________________
*** Configuration: WINCE ***
precompiling:
GPC - GLBasic Precompiler V.2009.113 - 3D, NET
Wordcount:18 commands

compile+link:
/cygdrive/C/DOKUME~1/KOSTAQ~1.000/LOKALE~1/Temp/glbasic/gpc_temp1.cpp: In
   function `DGInt __GLBASIC__::GPS_GetPosition(DGInt&, DGInt&, DGInt&, DGInt&,
   DGInt&)':
/cygdrive/C/DOKUME~1/KOSTAQ~1.000/LOKALE~1/Temp/glbasic/gpc_temp1.cpp:178: error: `
   flSpeed' undeclared (first use this function)
/cygdrive/C/DOKUME~1/KOSTAQ~1.000/LOKALE~1/Temp/glbasic/gpc_temp1.cpp:178: error: (Each
   undeclared identifier is reported only once for each function it appears
   in.)
/cygdrive/C/DOKUME~1/KOSTAQ~1.000/LOKALE~1/Temp/glbasic/gpc_temp1.cpp:179: error: `
   flHeading' undeclared (first use this function)
*** FATAL ERROR - Bitte die Compiler-Ausgabe ins Forum kopieren
_______________________________________

19
nein, leider nicht,

aber wenn du auch was mit einem Windows Mobile (2003 - zweite Ausgabe) (Version 4.21.XXX) mit GPS was zum testen brauchst... so ein Teil habe ich.

20
FAQ / Re: GLBasic license and updates
« on: 2009-May-10 »
do you mean updates or upgrades (for example from 2d to 3d, net,...)?

for updates never paid extra.
the upgrade prices are listed in the GLBasic website. (http://www.glbasic.com/main.php?lang=en&site=order)

21
GLBasic - de / Re: Immer ?rger mit Vista xD
« on: 2009-Apr-28 »
Niemand ne idee?

nicht wirklich...

4 Sachen noch...:

a) Sieht es im abgesicherten Modus genauso aus (mit der CPU-Auslastung)
b) Kannst du mal ein Screenshot machen vom Taskmanager/Prozesstabelle (sortiert absteigend (CPU-Auslastung))

c) Hast du evtl. Spybot (Search&Destroy) installiert?
Wenn ja, kannst du ein Screenshot machen von folg. Auswahlschirm: Werkzeuge -> Systemstart

d) Sind alle Vista updates installiert? (Nicht dass er im Hintergrund versucht noch die fehlenden Updates nachzuinstallieren).
Evtl. lurzfristig die Autom. Updatefunktion abschalten (wenn noch nicht alle Updates installiert sind)

22
GLBasic - de / Re: Immer ?rger mit Vista xD
« on: 2009-Apr-20 »
wechselt zwischen i.explorer (20-45%), explorer(15-17%), sogar der Taskmanager taucht manchmal an der Spitze mit 7% auf...

Nein, das sieht eigentlich gut aus.
Im Prinzip hast du kein Prozess der "Amok" l?uft und die CPU alleine besch?ftigt.

der Taskmanager zeigt aber weiterhin 100% Gesamt-CPU Verbrauch an?

Kannst du mal den neuesten Grafikkartentreiber der f?r deine Grafikkarte verf?gbar ist installieren?

Wieviel RAM hast du?  (wenn genug vorhanden ist, bitte mal testweise auf die Auslagerungsdatei verzichten) und schauen ob es sich bessert. Bzw. wenn du 2. Festplatten hast, die Auslagerungsdatei auf der anderen Platte legen als deine Windows-System-Installation.
Evtl. ist auch die Festplatte defekt, so dass dein ganzes System verz?gert wird, hast du ein Testprogramm um die Festplattengeschwindigkeit zu testen (je nach Alter sollten Werte zwischen 15MB (5 Jahre alte Platte) und 90MB (aktuelle Platte) erscheinen.

23
GLBasic - de / Re: Immer ?rger mit Vista xD
« on: 2009-Apr-18 »

Platz 1: Internetexplorer (27MB)
Platz 2: explorer (17MB)
...
Platz 5: sidebar (5MB) obwohl ich die eigendlich deaktiviert hab :rant:


Nicht nach Speicherauslastung, sondern nach CPU-Auslastung sortieren.
M?sste ein Tabellenreihe davor sein (ich hab hier vor mir nur ein XP - m?sste doch bei Vista auch so sein?)



[attachment deleted by admin]

24
GLBasic - de / Re: Immer ?rger mit Vista xD
« on: 2009-Apr-18 »
Ausserdem l?uft die CPU (3Ghz) immer auf 100%...

Liegt auch nicht an diversen Programmen, ist nur AntiVir drauf ;-)


Laufen alle 4 Kerne auf 100%? (falls nur einer angezeigt wird -> Verlauf kann man umschalten)
L?uft die CPU auf 100% wenn du GLBasic laufen hast, oder auch ohne?
Hast du den AntiVir Guard mal beendet..und geschaut ob die CPU-Last runtergeht.
Wenn du dir die laufenden Prozesse anschaust, sortier doch nach CPU-Auslastung -> welcher Prozess zeigt die meiste CPU-Auslastung an?

25
GLBasic - de / Re: Wo ist hier der Fehler??
« on: 2009-Apr-14 »
Was meinst du mit "Es l?sst sich nicht starten"?

der Kompiliervorgang?  ..was kommt denn f?r eine Meldung?

26
GLBasic - en / Re: Weird GLBasic problem
« on: 2009-Feb-16 »
Have you tried the example of Moru?


Code: GLBasic [Select]
DEBUG "line 1\n"
PRINT "Hello world", 50, 50
DEBUG "line 2\n"
KEYWAIT
DEBUG "line 3\n"
END

(activate Debug-Mode), execute it, and then -> take a look in your IDE (the Output Area (bottom)).... if all Debug-Lines are printed.

27
Bug Reports / Re: Problem mit Dualcore
« on: 2009-Feb-03 »
was verstehst du genau unter laggen?

wird alles langsam....oder erhöht sich der CPU-Verbrauch?


nutze GLB zwar nicht an meinem Dualcore (ist ein HTPC: lässt sich so schlecht mit der Fernbedienung programmieren  =D), aber bei meinem Quadcore habe ich sowas nicht bemerkt....

28
Bug Reports / Re: Problem mi dem Vollbildmodus
« on: 2009-Feb-02 »
SP3 problem?

ich kann das auch nicht mit XP (SP3) reproduzieren.

29
da ist zuviel grau...


also graue Schrift auf grauem Hintergrund geht garnicht,

mach Schrift weiss und beim drüberfahren schwarz, oder umgekehrt.... (darf ruhig etwas kontrast rein)

30
GLBasic - de / Re: Sprite-Scrolling
« on: 2009-Jan-20 »
very strange....

Programmier dir doch ganz schnell mal ein Beispiel, mit einem Sprite, das du mit Cursor links/rechts verschieben kannst, und zusätzlich gibst du noch mit Print die x/y-Variablen deiner Figur an (oder als Debug-Meldung).

Dann siehst du ja ob das so komisch ist....

Code: GLBasic [Select]
GLOBAL x=40;y=180
LOADSPRITE "sprite.bmp", 10
WHILE TRUE
  IF KEY(203) = 1 THEN DEC x,1
  IF KEY(205) = 1 THEN INC x,1
  DRAWSPRITE 10,x,y
  PRINT "X: "+x+" Y: "+y,100,100
  SHOWSCREEN
WEND
END
 

Hast du im Spiel ein scrollbaren Hintergrund?  vielleicht hast du die falschen x-Werte kontrolliert?

Pages: 1 [2] 3 4 ... 11