GLBasic forum

Other languages => GLBasic - es => Topic started by: msx on 2016-Aug-26

Title: ¿Alguien con Android 6.0?
Post by: msx on 2016-Aug-26
Hola, he publicado una aplicación en Google Play y un usuario se queja de que se sale de la aplicación nada más empezar. He visto que tiene un galaxy S7 con Android 6.0. Yo no la he podido probar en esa versión, ¿alguien me haría el favor para decirme que ocurre?.

Gracias
Title: Re: ¿Alguien con Android 6.0?
Post by: mentalthink on 2016-Aug-27
Lo siento , no tengo Android... pero ponlo mejor en el foro Inglés, porque aquí me parece que quedamos 2 gatos... que somos tu y yo... Por cierto que me parece súper interesante eso de que puedas captar la situación de los radares y tal. Ya nos explicaras un poco el asunto.
Title: Re: ¿Alguien con Android 6.0?
Post by: msx on 2016-Aug-27
¿En que OS desarrollas ahora?, para iOS no se puede ya, ¿no?.
Title: Re: ¿Alguien con Android 6.0?
Post by: mentalthink on 2016-Aug-28
Estoy más centrado en temas de PC, con el asunto de Steam(Supongo que GLbasic podrá exportar de esta manera, hay un usuario que tiene un juego en Steam creo)  y tal, pero si te digo la verdad lo tengo un poco de lado, estoy aprendiendo poco a poco C++ y Python.
El tema de los juegos y más en moviles lo veo cada vez más chungo, hay tanta gente haciendo juegos que la verdad...

Sobre lo de exportar a iPhone, me parece que si... vamos no creo que hayan quitado el soporte, aunque con la de mierdas que hacen los de Apple a saber, se dedican más a fastidiar a los desarrolladores que ayudarlos, aún recuerdo al principio del desarrollo con Apple, que se les metió entre ceja y ceja que había que programar por obligación el Objective-C,,,
Title: Re: ¿Alguien con Android 6.0?
Post by: msx on 2016-Aug-28
Vaya, tenía ganar de jugar a Black Sun en el iPhone, espero que no abandones el proyecto y lo saques en Steam al menos.
Title: Re: ¿Alguien con Android 6.0?
Post by: mentalthink on 2016-Aug-29
No MSX no lo he abandonado, de hecho lo sigo haciendo, lo he empezado de nuevo, aprender C++ , me ha ayudado un montón en hacer mejor el código...

Lo que pasa que hacerlo para mobiles, primero que no tengo nada para desarrollar, tengo un android con 2.3 y el iPod con el 5.1 o algo asi, y no tengo ni mac, ni quiero montar un hakintosh ni nada de eso.

Lo sacaré lo más seguro en PC , para las 3 plataformas en Steam, supongo que pondrán un exportador o algo asi, ya que creo que SpaceFractal tiene un juego en la Steam.

Poco a poco ahora mismo no lo tengo como prioridad pero voy haciendo.
Title: Re: ¿Alguien con Android 6.0?
Post by: Alex_R on 2016-Aug-30
Hola!! Que no, que quedamos 3 gatos. Yo también ando por aquí, aunque hacía tiempo que no le echaba un vistazo al foro en Español. Creí que estaba muerto.

Yo programo para IOS y mi última aplicación va muy bien. Tengo beneficios gracias a las in app purchases! GlBasic compila muy bien para Ios gracias a que Spacefractal hizo que compilara para 64bits. Lo que no entiendo es por qué los archivos para compilar en IOS no están en la sección de descargas oficial. Los tienes que descargar del foro. Pero van muy bien.

Siento no poder ayudarte con Android. No tengo nada de Android y nunca he programado para Android.
Title: ¿Alguien con Android 6.0?
Post by: msx on 2016-Aug-30
Yo me descargué un pack de iOS+Android de spacefractal pero no he conseguido que me salga la opción para compilar en iOS. Hay que hacer algo especial?


Enviado desde mi iPhone utilizando Tapatalk
Title: Re: ¿Alguien con Android 6.0?
Post by: Alex_R on 2016-Aug-30
No hay que hacer nada complicado. Simplemente sustituye la carpeta de ios (quizá es iPhone?) en Plattform Compiler (creo que es ese el nombre de la carpeta donde están todos los compiladores) y debería funcionar. Ahora no tengo mi ordenador con glBasic pero en las instrucciones de Spacefractal está explicado el proceso.
Title: Re: ¿Alguien con Android 6.0?
Post by: hardyx on 2016-Aug-30
Somos cuatro gatos, yo soy el cuarto gato :D.

Yo trabajo con Android y en la versión 6 han cambiado muchas cosas, la han liado a lo grande. Ahora las apps necesitan permisos y han quitado librerías de red obsoletas. No tengo telefonos con el 6, pero te puedo decir que pongas en el manifest.xml targetSdkVersion="19" que es el Android 4.4 y te va a funcionar en todas las versiones. Porque como pongas el último target (api 23) vas a tener que cambiar tu app de arriba a abajo solicitando permisos cada vez que uses la cámara, el GPS, y mil historias más.

Aqui tienes más info de los cambios:
https://developer.android.com/about/versions/marshmallow/android-6.0-changes.html
Title: Re: ¿Alguien con Android 6.0?
Post by: msx on 2016-Aug-30
Ostras hardyx creo que podría ser eso, yo tengo puesto ahora en target 22 pero en un emulador de Android 6 he visto en otra aplicación que pedían permiso para usar el GPS y en mi aplicación no y crashea. Probaré tu recomendación.


Enviado desde mi iPhone utilizando Tapatalk
Title: Re: ¿Alguien con Android 6.0?
Post by: msx on 2016-Sep-01
Pues no, no era eso. Resulta que en Android 6 por lo que sea cada vez que quieres hacer uso de un archivo tienes que poner DOESFILEEXIST para que se cargue desde la memoria y puedas acceder. Supongo que hará algo parecido a lo que hacía el Check_Assest del AndroidExtras. Ésto no es necesario para otros Android inferiores.
Title: Re: ¿Alguien con Android 6.0?
Post by: hardyx on 2016-Sep-01
No me suena eso, aunq nosotros lo tenemos todo en nativo. Asegurate de q usas los permisos de lectura y escritura en sd en el manifest. Si usas el target 19 te da todos los permisos sin preguntar, ya q es como una emulacion de lo q hacia antes.
Title: Re: ¿Alguien con Android 6.0?
Post by: msx on 2016-Sep-02
Yo programo para IOS y mi última aplicación va muy bien. Tengo beneficios gracias a las in app purchases! GlBasic compila muy bien para Ios gracias a que Spacefractal hizo que compilara para 64bits. Lo que no entiendo es por qué los archivos para compilar en IOS no están en la sección de descargas oficial. Los tienes que descargar del foro. Pero van muy bien.

¿Podrías explicar como se añade la opción de compilar en iPhone?, he instalado la carpeta iPhone de spacefractal en Platform pero al intentar compilar no me aparece la opción el GLB, no se si hay que configurar algo más.