GLBasic forum

Main forum => GLBasic - en => Topic started by: MrPlow on 2016-Jun-16

Title: New fix for Playstore required
Post by: MrPlow on 2016-Jun-16
Hi SF et al.

See link here
https://support.google.com/faqs/answer/7011127 (https://support.google.com/faqs/answer/7011127)

Seems another vulnerability issue found. Is there a quick way to fix this?

An edit to SDL?

Thanks
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Jun-16
Found reference in PLatform > android > lib > libpng_gf.a file

But not sure how to go about updating - downloaded the last version of libpng 1.623

Anyone got an ideas?
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Jun-16
Without this fix - no new updates or apps will be accepted on Playstore!
So its kind of a big deal :)
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Jun-16
we will fix it, but no hurry throught. Currectly we use 1.4.2, and can only staying using 1.4.x for glbasic. 1.6 is not 100% compatible, which require some require to the glbasic loader.

But will try to update it to 1.4.19 in this summer. Should not been a bigger issue.
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Jun-16
great thanks!
Looks like the update ban starts in September so that gives time... :)
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Jun-16
Seens its compile fine with 1.4.19, but still not tested. so its just matter to update the *.c files. Glbasic source code is required to compile it with this kind of issues.
Title: Re: New fix for Playstore required
Post by: Kitty Hello on 2016-Jun-17
Send me an email, please :)
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Jun-17
Im do. seens easy. Just use 1419, which seens compile fine without Recode...
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Jul-06
Hi Guys

Any update on if this fix is coming soon...I have ~20 apps to re-compile and re-test and upload
Also I would prefer a fix that didnt force me to update my GLB version as I am currently using v12

Thanks :)
Title: Re: New fix for Playstore required
Post by: Kitty Hello on 2016-Jul-06
Got it. I'll upload a fix these days.
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Jul-06
This issue was pretty much pretty simple to fix without im neede to help (14.19 is fine).

We now need to see the ip6 thing (for all platforms really, its would seen been required).  All im thinks is needed is simply just remove the net commands. Im do not have checke Apple does techincal check it or not, but more practical checking it.

Im dont see many does use those network commands with Android And iOS anyway, more on Windows. So im thinks we could remove it with DEFINE tag.

Currectly im do have focus on my Steam release, but im do ran into trouble to include steam Works correctly (also due too old gcc version).

PS. We also need to update the gcc compiler to Windows.
Title: Re: New fix for Playstore required
Post by: Schranz0r on 2016-Jul-06
PS. We also need to update the gcc compiler to Windows.

thats a pain i guess
Title: Re: New fix for Playstore required
Post by: Kitty Hello on 2016-Jul-11
Not really. Just a lot to make a new setup with a reasonable file size.

Gesendet von meinem GT-N7100 mit Tapatalk

Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Jul-18
Any update on this yet?
Title: Re: New fix for Playstore required
Post by: Paul Smith on 2016-Jul-18
looks like this has just been fixed in the v14 update.Just read that you use v12.

change log
14.329
   // Win32:
   //    KEY(cursor) was not always correct.
   // New command:
   //    BUSY - skip the next few HIBERNATE calls
   // libPNG:
   //    updated to version 1.4.19 (security issues)
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Jul-19
Gernot, can you email changes you have done for me? So im can make sure we are in sync? Im will also update the libPNG issue for AndroidExtras, so v12 also can been used in this week.
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Jul-26
Any joy yet on this - I myself need the fix to work for v12 GLB - manual file copying a new update is fine if that will fix it :)
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Aug-10
If pointed in the right direction could I fix this myself? Is it complex to make the new libpng files?

Time is ticking on this as deadline is september after which NO updates or new apps will be allowed without this fix.

:)
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Aug-11
Get your apps to get works with v14 instead. It's the way to go.

Actually I'm only so one source code base to compile.

V14 should been compatible with v12 as long you don't use new commands.
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Aug-12
Hi SF,

So is the libpng issue fixed in v14 already then?

Are there any mobile-specific bugs still to be addressed in v14?

I may look at v14 when I have more time to transition my apps over...hopefully all will work first time.

Title: Re: New fix for Playstore required
Post by: msx on 2016-Aug-12
GLB v14 does not update libpng.
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Aug-12
update it using web update. Gernot should have fixed it. Its just matter to update to the newest 1.4 version of it and then compile as its are. Im pretty sure its that Gernot did.

Im do need to wait to update mine, until im make sure me and Gernot is in sync.
Title: Re: New fix for Playstore required
Post by: Paul Smith on 2016-Aug-12
I think an auto-update on the IDE needs auto enabling.. I mentioned that this was fixed on the 16th of last month.People missing or not reading the whole post.
Title: Re: New fix for Playstore required
Post by: msx on 2016-Aug-12
You're right, I had an outdated version. Later I will try if it has been fixed.
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Aug-12
bot its different between glbasic 12 and 14. For Android its should not been a issue. Its same libraries used for both.
Title: Re: New fix for Playstore required
Post by: msx on 2016-Aug-13
The problem persists on GLB v14.329.
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Aug-13
Im waiting to get Gernot email me, but there is some email issues yet. Then im will update Android Extras as well. Im want have me and Gernot have the same source code before im release new AE, which would been possible to remove the inapp purchase stuff (example on Amazon).

my email was changed, but im have pm him my email.
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Aug-14
So would the fix for v14 work if the libpng related .h files were copied to v12??
Title: Re: New fix for Playstore required
Post by: spacefractal on 2016-Aug-14
v12 is begin to been old, so im can no longer garanti anything works. The issue is the file libpng_gf.a.

You might can copy the v14 version over to the v12 folder. There is no other changes than just updating the c code.

Here is the compiled version of it using v1.4.19, its a direct compiling with no other changes.

Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Aug-14
Thanks SF!

Excellent, I have recompiled one of my apps with the libpng new file in the compiler/android/libs folder

:)

Android devs, (verify libpng version)
To check for libpng version (post-compile) open glbasic-debug.zip > lib > armeabi > libmain.so (notepad.exe)
search for '1.4.19' to find libpng version if present it should be okay :)
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Aug-15
And just to confirm this simple file change has fixed the Google Fix Issue for me!
:)

So any devs still with issues only need to copy the file provided by SF here.

Title: Re: New fix for Playstore required
Post by: msx on 2016-Aug-15
 spacefractal :nw:
Title: Re: New fix for Playstore required
Post by: Kitty Hello on 2016-Aug-18
Uploaded an update last night.
Title: Re: New fix for Playstore required
Post by: Ian Price on 2016-Aug-18
:)
Title: Re: New fix for Playstore required
Post by: MrPlow on 2016-Aug-18
 =D
Title: Re: New fix for Playstore required
Post by: msx on 2016-Aug-18
 :good: