GLBasic forum

Main forum => GLBasic - en => Topic started by: Gary on 2015-Nov-27

Title: windows exclamation sound playing at start up of app
Post by: Gary on 2015-Nov-27
Ive noticed a strange quirk of my add in that when I run it in debug mode I do not hear a windows exclamation beep but if I turn off debug mode I am getting the sound which is a bit annoying.

Does anyone know where I could be going wrong? I am using version 10 (Yes I know, very old but I'm reluctant to upgrade until the project is finished as it could mess up the whole project) on a windows xp computer. Upgrading the main system is not an option before anyone says stick windows 10 on it :) I would have thought if there was an error (like missing file etc) causing the exclamation sound that the debug window would have shown the error

Thanks
Gary
Title: Re: windows exclamation sound playing at start up of app
Post by: MrTAToad on 2015-Nov-27
Cant say I have noticed any sound, although if the keyboard buffer is full then you may hear some beep
Title: Re: windows exclamation sound playing at start up of app
Post by: CptnRoughnight on 2015-Nov-27
Hey folks,

maybe you're trying to set a resolution your monitor is not able to. Does it start in windowed mode although you set it to fullscreen? Then check your resolution-settings.

Title: Re: windows exclamation sound playing at start up of app
Post by: Gary on 2015-Nov-27
Im using a borderless windowed mode as I have a dual monitor set up and it was the only way I could get it to span the 2 without going into settings and changing things which again is not an option.

I am sure it did not do it on the first version I wrote but unfortunately that code is long gone after a break in at work where they stole my computer and the back up drive and the backup USB stick that for the first time in years I forgot to take out and home with me :( had to rewrite about a months worth of work. (and because work had issues with internet the online backup was failing as well, a catalogue of errors that has taught me to check check check that everything is backed up realtime). I am pretty certain that I have rewritten the display code the same way. As its running on a 3rd party cabinet and none of the other software on there uses the exclamation sound I might add a KILLFILE when the program runs, then it will beep once and never beep again :)
Title: Re: windows exclamation sound playing at start up of app
Post by: CptnRoughnight on 2015-Nov-27
Just tested it.
I'm using a laptop (1366x768) +  monitor (1920x1080) in expanded mode.

This Code will work fine (GLB14.106 with and without debug)

Code: GLBasic [Select]
SETSCREEN 1920,1080,TRUE
 

But when i choose some other, unusual resolution like

Code: GLBasic [Select]
SETSCREEN 800,400,TRUE
 

the program try to establish the fullscreen, monitor(graphicscard) says no. Windows exclamation beep. Switched to Windowed mode.
Maybe there are other circumstances which lead to this behavior.