Author Topic: Verzögerung Input  (Read 415 times)

Offline WPShadow

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1641
    • View Profile
    • http://lostrevenant.blogspot.com
Verzögerung Input
« on: 2017-Jul-05 »
Hi,

hat jemand ähnliche Probleme mit Input  - Verzögerungen wie ich?

Teilweise dauert die Reaktion auf einen Tastendruck bis zu einer Sekunde.

Gilt allgemein, auch für ESC oder normale KEY() - Abfragen.

LG

W.

PS.: bevor jemand fragt --> ich hab das selbe Phänomen auf 3 Rechnern  =D
« Last Edit: 2017-Jul-05 by WPShadow »
AMD X2 4600, 2 GB Ram, ATI X1950 XTX, XP PRO SP2: GLB Premium 10.beta_dingsi, <(´.´<) Kirby Dance (>`.`)>
http://lostrevenant.blogspot.com
alea iacta est

Offline WPShadow

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1641
    • View Profile
    • http://lostrevenant.blogspot.com
Re: Verzögerung Input
« Reply #1 on: 2017-Jul-05 »
Hat sich gerade erledigt. Es dürfte ein kleiner Bug sein, der mit der FPS - Rate zusammen hängt.

Stelle ich max. Framerate auf -1 läuft der Input wieder korrekt.

Ich lasse das mal hier stehen, falls noch jemand den Fehler haben sollte.
AMD X2 4600, 2 GB Ram, ATI X1950 XTX, XP PRO SP2: GLB Premium 10.beta_dingsi, <(´.´<) Kirby Dance (>`.`)>
http://lostrevenant.blogspot.com
alea iacta est

Offline WPShadow

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1641
    • View Profile
    • http://lostrevenant.blogspot.com
Re: Verzögerung Input
« Reply #2 on: 2017-Jul-10 »
Hi,

könnt ihr euch das bitte mal ansehen? Ich hab euch mal das File meines aktuellen Projekts angehängt.

Ich habe bei der Keyboard - Eingabe Verzögerungen.

Sobald ich auf eine Taste drücke, bewegt sich die Map mit bis zu einer halben Sekunde Verzögerung.

Aktuell sind die Tasten W & S, F1 und F2 eingebunden.

Das selbe gilt für alle anderen Tasten incl. ESC.

LG

W.
AMD X2 4600, 2 GB Ram, ATI X1950 XTX, XP PRO SP2: GLB Premium 10.beta_dingsi, <(´.´<) Kirby Dance (>`.`)>
http://lostrevenant.blogspot.com
alea iacta est

Offline D2O

  • Prof. Inline
  • *****
  • Posts: 1032
    • View Profile
    • http://www.deuteriumoxid.com
Re: Verzögerung Input
« Reply #3 on: 2017-Jul-10 »
Läuft bei mir ohne verzögerung.
I7 2600K; 8 GB RAM ; Win10 Pro x64 | NVidia GTX 750 TI 2048MB ; Realtec OnBoard Sound;
Lenovo ThinkPad T400: XP Pro
GLB Premium-immer Aktuell

Offline WPShadow

  • Administrator
  • Prof. Inline
  • *******
  • Posts: 1641
    • View Profile
    • http://lostrevenant.blogspot.com
Re: Verzögerung Input
« Reply #4 on: 2017-Jul-11 »
Dann kann ich es wohl auf den Editor beschränken.

Sobald dieser offen ist (unabhängig ob Debug Modus an oder nicht) verzögert sich die Eingabe.

Scheinbar funktioniert das Endprodukt dann dennoch.

Damit kann ich leben. Danke dir!
AMD X2 4600, 2 GB Ram, ATI X1950 XTX, XP PRO SP2: GLB Premium 10.beta_dingsi, <(´.´<) Kirby Dance (>`.`)>
http://lostrevenant.blogspot.com
alea iacta est

Offline Worebu

  • Mr. Polyvector
  • ***
  • Posts: 132
  • Moin, Moin
    • View Profile
Re: Verzögerung Input
« Reply #5 on: 2017-Aug-18 »
hmm. Warum springt bei mir der Virenscanner (Bitdefender) an?
PC: Intel I7 3770K, 32GB DDR3, GTX1060 6GB,  480GB SSD, 1x2TB, 1x1TB, 2x ext. 1TB USB3.0, 1x ext. 2TB USB3.0, W10 x64 Pro, WaKü