Author Topic: Admob version  (Read 728 times)

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1313
    • View Profile
Admob version
« on: 2017-Dec-28 »
AE with Admob

Can Spacefractal or someone else tell me what version of Admob was used in older AE 2.9 etc.?

Google announced stopping ads for certain versions soon -  Jan 23rd.
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1313
    • View Profile
Re: Admob version
« Reply #1 on: 2017-Dec-28 »
Just found this post with an update from a while back - I dont think I did this update but just testing it now and so far so good.

working and running app as normal using play services 7895000
So what admob is in this play services?

Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1313
    • View Profile
Re: Admob version
« Reply #2 on: 2017-Dec-28 »
Okay seems that with this version SDK 7.8
All should still be good with Admob...I think
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3473
    • View Profile
    • Space Fractal
Re: Admob version
« Reply #3 on: 2017-Dec-29 »
quite old version.... and no, im cant update it without Android Studios, im using the most recent standalone SDK before its got depreacted.

Its a bigger project really, and im somewhere very uninspirated or not have time. Im have recently prepare a Spectrum Next game (which a port might become for Windows). Im have not started codning of it and its might not been even in glbasic, but in Construct3, due the style of the game fit it perfectly.

Sorry MrPlow. Im can no longer help with admob at all. Im will remove it anyway, due crappy requiremments with a LOTS of GB download for so small a thing, which im fell very stupid and all those issues with newer Android version. Im did newer got the ads to work again after SDK upgrade.

Actuelly with glbasic we should have move completly to Android Studio for long time ago. Also im have not do anything with iOS, now im will do that.

Im are simply got uninsprated about codning and do various other thing instead.

So with Admob, im cant help anymore.


« Last Edit: 2017-Dec-29 by spacefractal »
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1313
    • View Profile
Re: Admob version
« Reply #4 on: 2017-Dec-30 »
hi Sf,

I have it working and showing ads with SDK 7.8.

So all is good again for now.

So I am still on AE 2.9 but popped in the SDk 7.8 and it works....so that should meet the Google version 7+ requirement.

I did not update my AE because my ads are generating a lot of money every month...I was afraid of losing it.

 :good:
« Last Edit: 2017-Dec-30 by MrPlow »
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline MrPlow

  • Prof. Inline
  • *****
  • Posts: 1313
    • View Profile
Re: Admob version
« Reply #5 on: 2017-Dec-30 »
Hey,
I might experiment with version 8+ of the SDK and see if that works too. :)
Comp:
Speccy-48k, Speccy-128k, Amigas, PCs

Offline spacefractal

  • Community Developer
  • Prof. Inline
  • ******
  • Posts: 3473
    • View Profile
    • Space Fractal
Re: Admob version
« Reply #6 on: 2017-Dec-30 »
im just angry the direction Google have taken with admob, as im can no longer integrate that in the newer SDK. So hence its needs to been removed.... or move it to Android Studio.

Im for some month ago tried to refix the admob, but no luck with Android 6.0 SDK. Ads can been loaded, but java callbacks was newer fired as its should. So.... its quite buggy too.

Also im have newer got a single paymant this year from either google and iOS, but im also have down priotity those platforms. Steam have been the way for me.
Greedy Mouse - Karma Miwa - Spot Race - CatchOut - Android Extras - is on a vacation trip, home before end of few days in jan.